A-A+

Linux的软件安装,常用软件简单安装使用

2013年02月06日 综合技术 暂无评论 阅读 593 次

当前Linux的软件包通常可以从发行版本光盘或从互联网上找到。其一般格式分源代码与可执行码两种。为节省磁盘空间或下载时间,绝大部分的软件都在打包后以压缩文件方式存在。

常见的软件包有如file.tar.gz、file.src.tar.gz、file.rpm等。

在介绍通用安装方法之前,有必要提醒各位首先养成一种良好的操作系统使用习惯。因为LINUX设计的先进性和多用户使用等特性,因此在整个的安装过程中你尽可能的遵循以下原则:
1、如果你不想把目录变的乱糟糟的话,在下载软件之前就得建好一个易读的目录。而不是只有你才能看得懂它代表什么意思。同时,也为了在下一次你在看到它时能很容易的想起,里面有些什么。
2、除非你纯粹是为了安装软件而安装软件,否则,在安装软件之前你都有必要拥有一个备份目录,最好是异地备份。专门用于存放你常用或重要的软件包。
3、在试用一个新软件之前,请勿在你当前运行公务或有重要数据但尚未妥善备份的机器上试运行。即你不能冒险。
4、在安装时尽量以ROOT身份执行各种命令。安装完成后再仔细检查权限。
5、安装时产生的临时目录尽量将其放到/tmp目录。一个具有良好操作使用习惯的开端是:你在一开始就把待安装的软件放到/tmp目录中去。在你确信已成功安装后,别忘了将其删去。
6、了解你的CPU与LINUX版本类型,下载适宜的软件包。若有多种格式存在,推荐选用RPM格式的软件包。因为它易用且不易出错。
好了,此时你可以开始了。

对于以.RPM结尾的软件包,你只需简单地执行rpm -ivh file.rpm就行了。如果它提示你还少了某些东西,那么你必需先把它补全。如果它提示该软件包已经被安装了,但或许已经不完整或其它原因你想强制安装该软件包,那么你就键入以下命令:rpm -ivh --replacepkgs file.rpm。

在安装RPM软件包时有可能会遇到各种冲突。特别的,当你在老版本中想要安装最新的软件包时,常常会有以下的一些类似提示:
failed dependencies:
kernel >=2.2.10 is needed by file.X.X.X
file.X.X.X=0.80.1 is needed by otherfile.y.y.y

此类信息表明,要想使用新软件你必需把LINUX的内核升级到2.2.10,同时,要想安装file.X.X.X,你还必需安装另一个软件包otherfile.y.y.y。利用--nodeps选项可以忽略软件包相关性问题的检查,但通常此做法不值得推荐。

对于以rpm格式打包的软件,如果你以前就有此软件的旧版本,你一般地得优先考虑是采用升级的模式而不是安装的模式,因为你可以将配置文件得以保留下来。即使老版本不存在,采用升级的模式也不会出错。
因此,你完全可以采用如下命令:rpm -Uvh file.rpm。
关于RPM的详细说明,请参见本站的其他文章:

由于LINUX提倡DIY以及倡导张扬个性,为了让该软件更适合你的机器,同时也为了崇尚开源以及共享的精神,一般也会以源码的形式提供下载。如果你得到的是此类软件包,你在解压缩后还得重新编译软件包。

首先将软件包放到/tmp目录中去,然后执行
tar zxvf file.src.tar.gz.

此时,你通常得看看解压后都有哪些目录,是否有README或INSTALL软件。如有,请先仔细阅读它。如果你看得懂,那么你就不用接着往下看本文档了。一般的步骤有:make;makeinstall这样两步。很明显,你会使用到gcc--这个应该在所有的发行版中都会提供。其间它通常会提问软件安装时放到哪个目录。你一般往/usr目录放就行了。如果你的/usr目录设置为只读分区(这样做通常是基于安全性方面考虑),那么你可以放到/home/bin/local/bin/file目录下。前提是,这也是你的好习惯之一。下次不会找不到就行了。

如果你使用的象是redhat这样知名的发行版本,其间会有一个直观和易于使用的软件包专用工具pkgtool。具体名字会因发行版本的不同而有所不同。此时,你只要在点点击击之间就能完成软件包的安装工作了。

给我留言

Copyright © 2011-2016 零下二十四度Theme By  Ality  京ICP备16007547号   关于本站

用户登录